Hace unos dias decidí darle una oportunidad de nuevo al cliente nativo de Spotify para Linux. La última vez que lo había utilizado había sido en 2008 o 2009 cuando era una versión beta con bastantes problemas de estabilidad, que tendía a apoderarse del puntero del ratón y cosas similares.

Para instalar el cliente de Spotify en Ubuntu Linux seguiremos los siguientes pasos:

#Editamos el archivo de origenes de software /etc/apt/sources.list y añadimos esta linea:

deb http://repository.spotify.com stable non-free 

#(Opcional) Añadimos la clave de Spotify para verificar que lo que descargamos viene firmado por ellos.
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 94558F59 

#Actualizamos la cache de APT para disponer de la información del repositorio de Spotify Linux
sudo apt-get update 

#Instalamos el cliente de Spotify Linux en Ubuntu
sudo apt-get install spotify-client

Hasta aquí todo bien. Pero puede darse el caso de que en algún ordenador no arranque el cliente Spotify cuando hagamos click en su icono en el menú de inicio. A mi en casa me funciona perfectamente y en el ordenador del trabajo me ha fallado, siendo ambos 15.04. Para intentar conseguir un poco más de información sobre por qué Spotify no arrancaba en mi Ubuntu, abrí un terminal y ejecuté el cliente desde linea de comandos:

javi@trabajo:~$ spotify
spotify: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

Vaya, pues le faltan unas librerías. Para ahorrarte trabajo, te diré que la versión 1.1 que busca Spotify ya no viene incluida en Ubuntu por tratarse de una versión antigua, por lo que deberás bajarte esas librerías desde un repositorio de Ubuntu de una versión anterior. Te dejo los enlaces aqui:

Librerias para Spotify Linux – libgcrypt 1.1 32 bits
Librerias para Spotify Linux – libgcrypt 1.1 64 bits

Una vez instalada la versión adecuada para nuestro equipo, spotify arrancará sin problemas.
spotify para Ubuntu Linuxhttps://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb